Thema: nomadsconnected plugin unter wordpress  (Gelesen 4667 mal)

Flynn

« am: 06. Mai 2010, 20:48 »
Hallo zusammen,

ich würde gerne das nomandsconnected Wordpress Plugin nutzen, jedoch gibts nur ziemlich allgemeine Anleitungen dazu. Ich habe die beiden API-Keys und würde gerne loslegen :D

Was muss ich denn tun um in den Genuss meiner Karte zu kommen? Ich lese nur ungern Quellcode und hoffe auf eine nette kleine Anleitung :)

Jens

« Antwort #1 am: 07. Mai 2010, 00:40 »
Hallo Flynn,

das ust ganz einfach und Quellcode brauchst du auch nicht lesen. Ich habe eine Seite/Page unter Wordpress angelegt und ganz unten siehst du dann, was du einstellen kannst/willst. Und schon ist die Karte da!!! Übrigens kannst du das Selbe auch in einem Post machen!!

karoshi

« Antwort #2 am: 07. Mai 2010, 07:08 »
Hallo Flynn,

die Anleitung kann man wirklich ganz kurz machen:
  • Du gibst Deine Route mit den Wegpunkten ganz normal in Nomads Connected ein.
  • Wenn Du in Wordpress eine Seite oder einen Artikel bearbeitest, hast Du bei aktiviertem Plugin eine zusätzliche Box, in der Du das Start- und Endedatum eingibst. Die Route für diesen Zeitraum erscheint dann auf der Karte im Artikel bzw. auf der Seite.

Das ist auch schon alles. Um die Datumsangabe etwas zu erleichtern, kannst Du auch aus den bereits vorhandenen Wegpunkten auswählen.

LG, Karoshi

Flynn

« Antwort #3 am: 07. Mai 2010, 09:03 »
Ahhhh! Hab die ganze Zeit bei den Widgets gesucht....

Es tut jetzt so halb... http://www.how2doit.de/route/

Problem ist, dass er mir auf der Edit-Page-Seite die Ziele nicht anzeigt, die Karte selbst enthält nur ein paar Striche. Wordpress sagt mir beim Editieren immer "You have no past waypoints.", aber irgendwie seh ich trotzdem die Punkte auf der Karte :D
Bin nicht tief genug in der Sache drin, daher wäre es klasse, wenn du mir sagen würdest wie ich das debugge (oder wenn du magst bekommst du au Zugriff auf das Blog - hat eh noch keine Inhalte).

Nicht über die etwas andere Ansicht wundern. Die Hybrid-Ansicht erreicht man einfach durch "nc_map.setMapType(G_HYBRID_MAP);" und die Höhe des div-Elements lässt sich auch bequem ändern. Sollte aber keinerlei Auswirkungen auf mein Problem an sich haben.

karoshi

« Antwort #4 am: 07. Mai 2010, 09:31 »
Problem ist, dass er mir auf der Edit-Page-Seite die Ziele nicht anzeigt, die Karte selbst enthält nur ein paar Striche. Wordpress sagt mir beim Editieren immer "You have no past waypoints.", aber irgendwie seh ich trotzdem die Punkte auf der Karte :D

Kann es sein, dass Deine Wegpunkte alle in der Zukunft liegen? ;)
Wenn Du die Edit-Page in NC meinst, hast Du da vielleicht als Ansicht "kürzlich" eingestellt statt "aktuell+geplant" oder "alle"?
 
Die Auswahl der "past waypoints" in Wordpress ist in erster Linie als Hilfe gedacht, wenn man einen Artikel über konkrete Stationen der Reise schreiben will. Und das macht man ja typischerweise erst hinterher.

Wenn Du z.B. eine Karte mit der Route Deiner Weltreise haben willst, dann trägst Du auf der entsprechenden Seite einfach die Daten des ersten und letzten Tags der Reise ein. Danach kannst Du den WordPress-Teil komplett vergessen, es wird einfach immer die Route angezeigt, die in NC eingegeben ist. Und wenn Du da was änderst, ändert es sich im Blog automatisch mit. Nur wenn Du die Reise verschiebst oder verlängerst, musst Du die Daten einmal anpassen. Genauso funktioniert das auch, wenn Du nur Teilstrecken (z.B. in einem einzelnen Land oder Kontinent) anzeigen willst. Einfach erster und letzter Tag -- das war's.

LG, Karoshi

Flynn

« Antwort #5 am: 07. Mai 2010, 09:52 »
Habe ich gemacht :(
Habe ersten und letzten Tag eingegeben...


Mein Problem ist: warum bekomme ich nur zwei Strecken statt einfach alle Verbindungslinien? Würde super gerne NC nutzen um einfach die ganze Route am Stück darzustellen. Allerdings auch während der Reise um einzelne Etappen zu skizzieren.

In NC sieht alles so aus wie es soll und die Verbindungslinien sind auch eingetragen. Klar, mit der Kürzlich Option zeigt er nix an - aber da 1.10 Abflugtermin ist, ist das ja so wie es sein soll :)

Bei mir steht - wenn ich 1.10.2010 als Start und 31.07.2011 als Enddatum im Wordpress eingebe "You have no past waypoints.". Das steht eigentlich immer da, egal wie sehr ich mit dem Datum spiele... Habe da noch nie irgendwelche Stationen - wie in NC - gesehen.

Verstehst du was ich meine oder reden wir aneinander vorbei? Kanns dir gerne mit Screenshot belegen :)
Siehe: http://how2doit.de/screen.png

karoshi

« Antwort #6 am: 07. Mai 2010, 10:28 »
warum bekomme ich nur zwei Strecken statt einfach alle Verbindungslinien?
Im WordPress Blog wird nicht die Edit-Ansicht der Route angezeigt (bei der alle Punkte verbunden sind), sondern die externe Ansicht (also so, als würde man eine fremde Route sehen, was ja auch für die allermeisten Besucher des Blogs tatsächlich der Fall ist). Hierbei werden Stationen mit einer Linie verbunden, wenn zwischen ihnen nicht mehr als 3 Tage liegen. Nur dann werden sie als zur selben Reise gehörig betrachtet. Es ist vorstellbar, dass das auch manuell eingestellt werden kann, aber in der jetzigen Version des Plugins ist das fix.

Wenn Du also überall Linien haben willst, musst Du für jede Station den tatsächlichen Zeitraum angeben und nicht nur beispielsweise den ersten Tag. Oder Du änderst das Plugin (in Zeile 233 in der aktuellen Plugin-Version 1.0.1).

EDIT: Inzwischen kann man das im Plugin einstellen.


Bei mir steht - wenn ich 1.10.2010 als Start und 31.07.2011 als Enddatum im Wordpress eingebe "You have no past waypoints.". Das steht eigentlich immer da, egal wie sehr ich mit dem Datum spiele... Habe da noch nie irgendwelche Stationen - wie in NC - gesehen.
Die Liste der vergangenen Wegpunkte in der Edit-Ansicht bei WordPress ist nicht die Liste der Wegpunkte, die später auf der Karte zu sehen sein werden, sondern eine Ausfüllhilfe für die Datumfelder. Du siehst da alle Wegpunkte, die schon vorbei sind, damit Du z.B. leicht eine Karte in einen Artikel über eine bestimmte Station Deiner Reise einfügen kannst, ohne das Datum erst mühsam in NC suchen zu müssen.

Wenn Dein erster Wegpunkt vom 01.10.2010 bis 02.10.2010 ist, dann wirst Du in dieser Liste erst am 03.10.2010 etwas sehen können, egal was Du in die Datumsfelder einträgst.

reden wir aneinander vorbei?
Jetzt hoffentlich nicht mehr. :)

LG, Karoshi

Flynn

« Antwort #7 am: 07. Mai 2010, 11:15 »
Ahh...okay, danke für die Hilfestellung :)

Hab mir erlaubt die Grenze etwas abzuändern und damit praktisch wegfallen zu lassen :)

Funktioniert nun alles so wie es soll :)

karoshi

« Antwort #8 am: 10. Mai 2010, 13:15 »
Inzwischen ist auf der Plugin-Seite auch eine Anleitung hinterlegt.

LG, Karoshi

Jens

« Antwort #9 am: 10. Mai 2010, 13:31 »
Das ist doch ein Suport!!

Flynn

« Antwort #10 am: 11. Mai 2010, 08:45 »
Ja, das ist wohl wahr! Ein riesiges Dankeschön an karoshi :)

Nomads connected is ne tolle Sache und ne super Idee. Vorallem die Tipps sind klasse!

cielo

« Antwort #11 am: 24. Mai 2010, 16:12 »
ich hab mir das mal installiert. leider hat dann einiges nach der installation nicht mehr funktioniert und ich musste es deaktivieren.
und zwar: wenn ich einen artikel erstellen wollte konnte ich keine tags mehr eintragen (feld blieb grau und man konnte nix abspeichern), auch konnte ich die icons zum bild hochladen etc. nicht anklicken, es passierte nichts. und wenn ich die bilder via html-ansicht hinzugefügt habe konnte ich sie dann in der "visuell"-ansicht nicht anklicken (da wo man sonst die größe, ausrichtung etc. ändern kann). links hinzufügen, text formatieren etc. funktionierte aber. alles sehr mysteriös. nach dem deaktivieren funzte alles wieder.

das problem trat unter windows 7, aktuellem wordpress, aktuellem firefox und aktuellem ie auf.
vielleicht magst du ja mal drüber schauen, karoshi?

karoshi

« Antwort #12 am: 24. Mai 2010, 17:23 »
In der Tat mysteriös... Wenn ich es bei mir probiere, funktioniert sowohl das Hochladen der Bilder als auch die Tags.

Meine Vermutungen:
  • Eventuell gibt es eine Unverträglichkeit mit einem anderen bei Dir installierten Plugin. Hast Du noch andere Plugins laufen, und wenn ja: kannst Du die probeweise deaktivieren und dann sehen, ob es geht?
  • Das von Dir beschriebene Fehlverhalten deutet auf einen JavaScript-Fehler hin. Vielleicht kannst Du in der Fehlerkonsole des Firefox etwas sehen. ("Extras/Fehlerkonsole") Notfalls erst mal alle Meldungen löschen und dann die Seite noch mal aufrufen, dann in der Fehlerkonsole nach unten scrollen und sehen, ob da ein Fehler (Warnungen sind egal) gemeldet wird.

LG, Karoshi

Jens

« Antwort #13 am: 24. Mai 2010, 17:54 »
Eventuell gibt es eine Unverträglichkeit mit einem anderen bei Dir installierten Plugin. Hast Du noch andere Plugins laufen, und wenn ja: kannst Du die probeweise deaktivieren und dann sehen, ob es geht?

wäre auch meine Vermutung

cielo

« Antwort #14 am: 24. Mai 2010, 18:41 »
ja, an javascript habe ich auch gedacht, aber irgendwie macht das alles keinen sinn.

ja, ich hab ne ganze menge plugins installiert. das alles auszutesten, dazu hab ich gerade keine zeit.
in die fehlerkonsole guck ich demnächst mal. muss jetzt erstmal los.

 

Diese Webseite verwendet Cookies. Hier erfahrt ihr alles zum Datenschutz
OK