Thema: Frage zur Nomad Map  (Gelesen 3215 mal)

Walter

« am: 14. November 2014, 13:40 »
Hi karoshi.

Zunächst einmal vielen Dank für den RTW-Blog sowie die regelmäßige Pflege und die Updates! Ich hatte damit auch mal was zu tun und ich weiß was das für Arbeit ist.

Ich habe nun noch eine Frage zu der Nomad Map. Für meine Reise habe ich eine entsprechende Karte mit Wegpunkten angelegt. Im Editor wird diese wie in den Einstellungen festgelegt mit den Linien angezeigt. Auf meinem Blog habe ich nun im Footer das Plugin eingebunden. Hier wird aber immer nur die letzte Position angezeigt. Gibt es eine Möglichkeit die Darstellung so wie im Routeneditor zu wählen, also mit den Wegpunkten und den Links zu den Blogeinträgen?


LG, Walter

karoshi

« Antwort #1 am: 14. November 2014, 14:26 »
Wenn Du sagst "im Footer", dann meinst Du offensichtlich das Widget. Damit kann man, soweit ich weiß, nur den aktuellen Aufenthaltsort anzeigen.

Wenn Du die Route mit den Links im Blog haben willst, musst Du die Karte über den Shortcode in den Inhaltsbereich einer Seite oder eines Beitrags einfügen. Die Anleitung dazu findest Du unter dem Menüpunkt "Nomad Map -> FAQ".


Walter

« Antwort #2 am: 14. November 2014, 17:18 »
Ja, das habe ich mir schon gedacht. Ich habe das mal testweise versucht und ein Text- bzw. HTML-Element genommen. Wenn ich da den Code eintrage, dann erscheint der als Text im Footer und nicht die Map. Er "erkennt" das quasi nicht als Platzhalter für die Karte. Wenn ich HTML-Code schreibe, nimmt er das aber an. Vielleicht liegt es an den eckigen Klammern?

karoshi

« Antwort #3 am: 14. November 2014, 21:04 »
Hast Du den Shortcode im Footer eingetragen? Ich glaube nicht, dass Shortcodes innerhalb von Widgets funktionieren.

Walter

« Antwort #4 am: 15. November 2014, 03:08 »
Ja, das habe ich versucht. Es geht wirklich nur in den Beiträgen. Ich habe es jetzt so gelöst, dass ich einen gesonderten Beitrag dazu angelegt habe. Diesen habe ich dann verlinkt. So geht das. Danke.

LG, Walter

Crung

« Antwort #5 am: 10. Juni 2015, 15:56 »
Hallo zusammen,

ich hänge mich mit meiner Frage bzw. meinem Problem mal hier dran:

Wenn ich beim Anlegen eines Wegpunktes unter "Location content" die Option "Custom content" wähle erscheint beim Speichern immer ein Fehler (Failed to save the data, please try again).

Egal welche Felder ich vorher ausfülle, der Fehler taucht immer wieder auf.
Bin ich da alleine oder taucht das Problem auch bei anderen Usern auf?
Und hat vorallem jemand eine Lösung parat?

Viele Grüße
Crung

karoshi

« Antwort #6 am: 12. Juni 2015, 18:06 »
Hallo Crung,

damit ich das Problem nachvollziehen kann, wäre es gut, wenn Du mir sagst (ggf. per PM), um welchen Blog es sich handelt.

LG, Karoshi

Crung

« Antwort #7 am: 14. Juni 2015, 21:23 »
PN ist vor 2 Tagen raus.

karoshi

« Antwort #8 am: 15. Juni 2015, 10:03 »
Hallo Crung, hab ich gesehen. Ich bin nur noch nicht dazu gekommen, der Sache auf den Grund zu gehen. Was ich bis jetzt sagen kann ist, dass ich den Fehler bei Dir reproduzieren kann, in meinem Testblog aber nicht.

Crung

« Antwort #9 am: 15. Juni 2015, 10:08 »
Alles klar, ist ja nicht ganz soo eilig.
War mir nur nicht sicher, da die Nachrichten ja nicht automatisch im Postausgang gespeichert werden.
Hatte nicht gesehen, dass man dazu einen Haken setzen muss.

karoshi

« Antwort #10 am: 15. Juni 2015, 14:30 »
So, inzwischen bin ich schon etwas weiter. Das Nomad World Map Plugin legt die Daten von Wegpunkten des Typs "Custom Content" in einer eigenen Tabelle in der Datenbank ab, und die hat bei Dir gefehlt. Warum das so war, weiß ich noch nicht. Eigentlich wird diese Tabelle bei der Aktivierung des Plugins angelegt, und da das bei neuen Blogs automatisch aktiviert ist, müsste die Tabelle eigentlich immer vorhanden sein.

Ich habe testweise das Plugin global deaktiviert, anschließend für Deinen Blog von Hand aktiviert, und dann war die Tabelle plötzlich da. Es scheint also einen Fehler bei der automatischen Aktivierung zu geben. Mal sehen, wie ich damit umgehe.

Crung

« Antwort #11 am: 15. Juni 2015, 14:58 »
Danke, habe es soeben erfolgreich Testen können  :)
Ich hatte das Plugin damals deaktiviert, ob damit die Tabelle verschwunden ist?

Bezüglich des Blogs habe ich dir auch noch eine PN geschrieben, da es um zwei Dinge geht, die nur auf administrativer Ebene vorgenommen werden können (wenn überhaupt so einfach möglich).

Grüße
Crung

mywittow

« Antwort #12 am: 23. Juni 2015, 13:35 »
Hi mittlerweile kannst du ganz einfach eine Map bei Google erstellen.
Diese kannst du mit Wegpunkten "aktuellen Standort" etc. besticken.

Anschließend kannst du diese problemlos in deinen Blog einbinden.

Crung

« Antwort #13 am: 29. Juni 2015, 16:06 »
So, inzwischen bin ich schon etwas weiter. Das Nomad World Map Plugin legt die Daten von Wegpunkten des Typs "Custom Content" in einer eigenen Tabelle in der Datenbank ab, und die hat bei Dir gefehlt. Warum das so war, weiß ich noch nicht. Eigentlich wird diese Tabelle bei der Aktivierung des Plugins angelegt, und da das bei neuen Blogs automatisch aktiviert ist, müsste die Tabelle eigentlich immer vorhanden sein.

Ich habe testweise das Plugin global deaktiviert, anschließend für Deinen Blog von Hand aktiviert, und dann war die Tabelle plötzlich da. Es scheint also einen Fehler bei der automatischen Aktivierung zu geben. Mal sehen, wie ich damit umgehe.

Hallo Karoshi,

neuer Blog, gleiches Problem  :(
Weitere Infos per PN.

Viele Grüße
Crung

karoshi

« Antwort #14 am: 29. Juni 2015, 21:27 »
Ich habe die automatische Aktivierung abgeschaltet. Wer das die Nomad Map verwenden will, muss das Plugin jetzt selbst aktivieren. (Installiert ist es schon.) Dann wird es auch korrekt initialisiert.

Dazu muss man in der Administrationsoberfläche den Menüpunkt "Plugins" auswählen, in der Liste den Eintrag "Nomad World Map" suchen und dort auf "aktivieren" klicken. That's it.

Tags:
 

Diese Webseite verwendet Cookies. Hier erfahrt ihr alles zum Datenschutz
OK