Thema: Fremdsprachen (Schrift) werden falsch dargestellt.  (Gelesen 1111 mal)

Stecki

« am: 20. Februar 2019, 13:10 »
Immer mal wieder werden mir Fremdsprachen (aktuell tschechisch) falsch dargestellt, das heisst gewisse Buchstaben mit Sonderzeichen werden als Fragezeichen dargestellt. Wenn ich den Beitrag verfasse sieht alles ganz normal aus, danach siehts aber komisch aus. Kann man dagegen etwas machen?

Beispiel: https://stecki.rtwblog.de/die-letzten-10-spiele/ (15.02. und 16.02.)

karoshi

« Antwort #1 am: 20. Februar 2019, 13:14 »
Hi Stecki,

wie gibst Du denn die Texte ein? Schreibst Du sie im WP-Backend mit dem "eingebauten" Editor, oder kopierst Du sie von irgendwoher?

LG Karoshi

Stecki

« Antwort #2 am: 20. Februar 2019, 14:01 »
Ich kopiere sie meist. Es wird auch nicht immer gleich dargestellt, manchmal ist alles korrekt.

karoshi

« Antwort #3 am: 21. Februar 2019, 08:29 »
An dem Kopieren dürfte es aber liegen. Was ist denn die Quelle, Microsoft Word? MS verwendet soweit ich weiß nicht den Standard-Zeichensatz UTF-8, sondern einen eigenen. Da sind zwar viele Sonderzeichen gleich, aber nicht alle.

Stecki

« Antwort #4 am: 21. Februar 2019, 09:17 »
Hm, unterschiedlich. Manchmal direkt von einer Website oder von Open Office.

karoshi

« Antwort #5 am: 21. Februar 2019, 18:30 »
Ich wage mal die Vermutung, dass das Kopieren von der Website Sonderzeichen verfälscht, wenn die Seite nicht in UTF-8 codiert ist. Du kannst ja mal gezielt drauf achten.

Wie das bei Open Office läuft, weiß ich leider nicht.

Stecki

« Antwort #6 am: 23. Februar 2019, 08:13 »
Danke, ich werde mal drauf achten und schauen was sich machen lässt.

Edit: Habe nun ein Bisschen rumprobiert und es klappt: Ich kopiere den Text erst in den txt-Editor, speichere ihn ab und kopiere ihn dann auf den Blog. Danach stimmt die Formatierung.

Tags:
 

Diese Webseite verwendet Cookies. Hier erfahrt ihr alles zum Datenschutz
OK